We've been monitoring the results of the fix to restore our users' ability to access PrecisionLender and everything looks good so far. We're closing this incident as resolved. However, we will continue to monitor performance.
We have identified the cause of the errors and have introduced a fix to restore access. Users may notice that they are able to access PrecisionLender again. We'll continue to provide updates, and if you have any questions, please contact PrecisionLender Support.
Posted Mar 19, 2025 - 12:52 EDT
Update
We are continue to investigate an issue where some users are reporting an Access Denied message when trying to access PrecisionLender. We're really sorry this is happening, and we'll provide another update as soon as more information is available. If you have any questions, please contact PrecisionLender Support.
Posted Mar 19, 2025 - 12:36 EDT
Investigating
We are currently investigating an issue where some users are reporting an Access Denied message when trying to access PrecisionLender. We're really sorry this is happening, and we'll provide another update as soon as more information is available. If you have any questions, please contact PrecisionLender Support.
Posted Mar 19, 2025 - 11:56 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02, PL-Application-AU-01, PL-Application-CAC-01).