Users are unable to access PrecisionLender through Dynamics
Incident Report for PrecisionLender.com
Resolved
Access to PrecisionLender through Dynamics is restored. We're closing this incident as resolved, but we will continue monitoring performance closely.

If you have any questions, please contact Support.
Posted Nov 05, 2019 - 17:45 EST
Monitoring
We've released a fix to restore access to PrecisionLender through Dynamics. This issue has been resolved, but we will continue monitoring performance closely.

If you have any questions, please contact Support.
Posted Nov 05, 2019 - 15:50 EST
Identified
We have identified an issue where users are unable to access PrecisionLender through Dynamics. We are currently working on a fix for this issue. We're really sorry about this and we will provide another update as soon as more information is available.

If you have any questions, please contact Support.
Posted Nov 05, 2019 - 14:22 EST
This incident affected: CRM and other integrations.