PrecisionLender Outage/ Degraded Performance

Incident Report for PrecisionLender.com

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 15:07 EDT

Monitoring

The issue has been identified. Users may experience intermittent interruptions while we continue to monitor further.
Posted Jul 13, 2026 - 11:21 EDT

Investigating

PrecisionLender Users are experiencing issues with all calls to our API and clients trying to access via a CRM connector. Users may be unable to access PrecisionLender
Posted Jul 13, 2026 - 11:11 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02), Andi (Andi Skills Manager, Andi Skills Processing, Andi Language Service), and CRM and other integrations, Data Explorer.