Users on US-01 are unable to access PrecisionLender
Incident Report for PrecisionLender.com
Resolved
We've been monitoring performance and everything looks good. Users are able to access PrecisionLender and price opportunities as normal. We're closing this incident as resolved, but if you have any questions, please contact PrecisionLender Support.
Posted Aug 09, 2023 - 15:59 EDT
Monitoring
We've implemented a fix for an issue that was preventing users from accessing PrecisionLender on US-01. Users should now be able to log in and price opportunities. We will continue to monitor performance closely.

If you have any questions, please contact PrecisionLender Support.
Posted Aug 09, 2023 - 10:23 EDT
Identified
We've identified an issue that is impacting user's ability to login to PrecisionLender on US-01. We're really sorry this is happening and are working quickly to restore access. We will provide an update as soon as we have more information.

If you have any questions, please contact PrecisionLender Support.
Posted Aug 09, 2023 - 10:14 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01).