PrecisionLender US-01 Outage
Incident Report for PrecisionLender.com
Resolved
This incident has been resolved, but we will continue monitoring performance closely.

Please contact PrecisionLender Support with any questions or issues.
Posted 10 months ago. Dec 19, 2018 - 14:10 EST
Monitoring
We have identified and fixed the cause preventing users from accessing PrecisionLender on US-01. Users should now be able to login, and we will continue monitoring performance.

Please contact PrecisionLender Support with any questions or issues.
Posted 10 months ago. Dec 19, 2018 - 14:04 EST
Investigating
We are currently investigating an issue preventing users from accessing PrecisionLender on the US-01.

To help determine if you are on US-01, please see our System Status support article.

Please contact PrecisionLender Support with any questions.
Posted 10 months ago. Dec 19, 2018 - 13:59 EST
This incident affected: PrecisionLender Application (PL-Application-US-01).