US-01 - Login Issues
Incident Report for PrecisionLender.com
Resolved
This incident has been resolved and users are able to log in successfully.
Posted Sep 11, 2023 - 14:30 EDT
Monitoring
The fix was applied successfully and logins are now running smoothly. We will continue to monitor and will keep you updated.
Posted Sep 11, 2023 - 12:55 EDT
Identified
We have identified an Azure issue that is causing errors when attempting to log in to PrecisionLender. We're very sorry for the interruption to your day! In 15 minutes we are implementing a fix that we expect to stabilize the system and will keep you updated on our progress as soon as more information is available.

To find which stack your financial institution is on, see System Status.
If you have any questions, please contact PrecisionLender Support.
Posted Sep 11, 2023 - 11:58 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01).