Treasury and FHLB-Boston rates
Incident Report for PrecisionLender.com
Resolved
As of January 8, 2019, all affected opportunities and historical Treasury and FHLB-Boston rates for the impacted dates were corrected. We have completed our root cause analysis and based upon our findings, have implemented immediate measures to ensure the accuracy of the Treasury rates that we receive. Further, we are investigating long-term solutions to continue to improve on the rate services that we provide. For more information on our root cause analysis, please reach out to support@precisionlender.com.
Posted 9 months ago. Jan 11, 2019 - 11:03 EST
Update
We have now reached out to clients who had opportunities we corrected as part of our fix for the incorrect Treasury rates on 1/2 and 1/8, and incorrect FHLB-Boston rates on 1/2. We are currently working on a root cause analysis for this incident, which we will share on this page. If you are seeing any rates that look incorrect or if you have any questions, please email us at support@precisionlender.com.
Posted 9 months ago. Jan 09, 2019 - 15:51 EST
Update
Our Treasury rates were fed incorrectly to us overnight from our provider. We have corrected the rates, so if you open a new opportunity now and use Treasury, your rates will be correct. If you priced a loan earlier this morning, please fast forward your pricing date to use the latest assumptions and re-save your loan. The loans affected by the earlier incorrect Treasury rates from 1/2 have been corrected, and we are in the process of reaching out to those clients. We know you rely on us to have accurate rates and pricing data, and we're sorry we let you down. We'll keep monitoring rates to make sure they're right, but if you have any questions or you want to talk further about this, please reach out to us at support@precisionlender.com.
Posted 9 months ago. Jan 08, 2019 - 11:12 EST
Monitoring
Our rate provider has been able to give us correct rates for both yesterday and today, but we will continue to monitor. We have identified opportunities affected, and will be reaching out to affected clients once we implement the fix. In the meantime, if you have an opportunity with a pricing date of 1/2 using one of these indices, you can quickly fix it by updating your pricing date to 1/3 or 1/4. If you have questions, please reach out to us at support@precisionlendercom and we'll be happy to help.
Posted 10 months ago. Jan 04, 2019 - 15:26 EST
Update
Our rates for today, 1/3, are correct for both US Treasury and FHLB-Boston. If you are pricing a loan with either of those as your index or funding curve, the 1/3 pricing date will have the most up-to-date rates. We are working to retroactively fix our Treasury and FHLB-Boston rates from 1/2. If you have an opportunity with a 1/2 pricing date, the quickest fix is to update your pricing date to today. We are also continuing to work with our rate provider to find the root cause of yesterday's incorrect rates, and from there ensure we have steps in place to keep this from happening again.
Posted 10 months ago. Jan 03, 2019 - 09:43 EST
Identified
We've identified an issue with our rates for US Treasury and FHLB-Boston. Those rates are incorrect in PrecisionLender for today, 1/2/19. We are working with our rate provider to get more information on what caused this, and we're working to get this resolved as soon as we can. We'll post again as soon as we have another update, but in the meantime, please avoid saving loans using either Treasury or FHLB-Boston with a 1/2 pricing date if possible. If you have any questions, please reach out to us at support@precisionlender.com
Posted 10 months ago. Jan 02, 2019 - 15:51 EST
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02).