PrecisionLender NA-01 Outage
Incident Report for PrecisionLender.com
Resolved
This incident has been resolved, but we will continue monitoring performance closely.

Please contact PrecisionLender Support with any questions or issues.
Posted 9 months ago. Jan 30, 2019 - 10:28 EST
Monitoring
We have identified and fixed the cause preventing users from accessing PrecisionLender on NA-01. Users should now be able to login, and we will continue monitoring performance.

Please contact PrecisionLender Support with any questions or issues.
Posted 9 months ago. Jan 29, 2019 - 19:42 EST
Investigating
We are currently investigating an issue keeping users from being able to access NA-01. Affected users will not be able to log in or price opportunities currently. We'll post another update as soon as we have more information.
Posted 9 months ago. Jan 29, 2019 - 17:10 EST
This incident affected: PrecisionLender Application (PL-Application-NA-01).