Delay in updating PrecisionLender Data Library reports for U.S. Clients

Incident Report for PrecisionLender.com

Resolved

All Data Library report re-runs successfully completed last night around 8:30 PM and everything looks good so far for today's Data Library processing. We're updating this incident to resolved, and thank you for your patience during this time.

If you have any questions, please contact PrecisionLender Support.
Posted May 07, 2025 - 09:05 EDT

Update

We have released a fix for the issues affecting Data Library report processing and are currently re-running all Data Library reports for today. We will provide another update as soon as this is completed.

If you have any questions, please contact PrecisionLender Support.
Posted May 06, 2025 - 13:51 EDT

Identified

We have identified an issue updating Data Library reports today in PrecisionLender for clients in the United States. We are actively working on a resolution, and we're really sorry this is happening. We will provide another update as soon as more information is available.

If you have any questions, please contact PrecisionLender Support.
Posted May 06, 2025 - 11:44 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02).