Users are unable to access the PrecisionLender application
Incident Report for PrecisionLender.com
Resolved
We've been monitoring the results of the fix to our infrastructure and everything looks good so far. We're closing this incident as resolved and will still continue monitoring.

If you have any questions, please contact PrecisionLender Support.
Posted 6 months ago. May 02, 2019 - 20:12 EDT
Monitoring
Precision Lender is operational at this time. Users should now be able to access the PrecisionLender application directly or through their CRM. Relationship Awareness uploads are also functional at this time. We will continue to closely monitor our Microsoft Azure infrastructure.

If you have any questions, please contact PrecisionLender Support.
Posted 6 months ago. May 02, 2019 - 18:32 EDT
Identified
We've identified an issue impacting access to PrecisionLender for all clients as being related to connectivity issues with our host server Microsoft Azure. Our developers are in communication with Microsoft as they work to understand what is happening, when we may be back online, and how we can help get you back to pricing your deals as quickly as possible. We're really sorry about this and will update you with the latest information as soon as it becomes available.

If you have any questions, please contact PrecisionLender Support.
Posted 6 months ago. May 02, 2019 - 16:32 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02, PL-Application-NA-01, PL-Application-AU-01) and CRM and other integrations, Relationship Awareness Processing.