PrecisionLender Degraded Performance - Save / Print Issues

Incident Report for PrecisionLender.com

Resolved

We've been closely monitoring the effects of the fix to restore proper functionality for saving, pricing, and printing Opportunities, and everything appears to be working well thus far. As a result, we're marking this incident as resolved but will continue to monitor.

If you have any questions, please contact PrecisionLender Support.
Posted Mar 05, 2025 - 17:17 EST

Update

Our team continues active monitoring of performance in PrecisionLender. If users continue to experience issues within Opportunities, have the users log out of the application, clear the browser cache and close all PrecisionLender windows/tabs before retrying to access the Opportunity.

If you have any questions, please contact PrecisionLender Support.
Posted Mar 05, 2025 - 16:16 EST

Monitoring

We have identified and released a fix for a caching issue that prevented some users from saving, printing, or pricing Opportunities in PrecisionLender. Users should now begin to work within Opportunities normally. We will continue to monitor performance closely.

If you have any questions, please contact PrecisionLender Support.
Posted Mar 05, 2025 - 15:25 EST

Identified

We have identified a caching issue and are working on a resolution. We will provide an update as soon as we have more information.

If you have any questions, please don't hesitate to contact PrecisionLender Support
Posted Mar 05, 2025 - 13:55 EST

Investigating

We are currently investigating an issue causing users to be unable to save or print opportunities in PrecisionLender. We're really sorry this is happening, and we'll provide another update as soon as more information is available.

If you have any questions, please contact PrecisionLender Support.
Posted Mar 05, 2025 - 13:07 EST
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02, PL-Application-NA-01, PL-Application-AU-01, PL-Application-CAC-01).