PrecisionLender users may be unable to login, open, or save opportunities
Incident Report for PrecisionLender.com
Resolved
We've been monitoring the results of the fix to restore our users' ability to login, open, and save opportunities and everything looks good so far. We're closing this incident as resolved and will continue monitoring.

If you have any questions, please contact PrecisionLender Support.
Posted Apr 07, 2020 - 12:33 EDT
Monitoring
We've implemented a fix and users should now be able to login, open, and save opportunities in PrecisionLender. We're really sorry this happened and will continue monitoring performance closely.

If you have any questions, please contact PrecisionLender Support.
Posted Apr 07, 2020 - 12:14 EDT
Update
We have identified an issue causing some users to be unable to login, open, or save opportunities in PrecisionLender. Our team is currently working on a fix to help get you back to pricing your deals as quickly as possible. We're really sorry about this and will update you with the latest information as soon as it becomes available.

If you have any questions, please contact PrecisionLender Support.
Posted Apr 07, 2020 - 10:30 EDT
Update
We have identified an issue causing users to be unable to login, open, or save opportunities in PrecisionLender. Our team is currently working on a fix to help get you back to pricing your deals as quickly as possible. We're really sorry about this and will update you with the latest information as soon as it becomes available.

If you have any questions, please contact PrecisionLender Support.
Posted Apr 07, 2020 - 10:11 EDT
Identified
We have identified an issue causing users to be unable to open saved opportunities in PrecisionLender. Our team is currently working on a fix to help get you back to pricing your deals as quickly as possible. We're really sorry about this and will update you with the latest information as soon as it becomes available.

If you have any questions, please contact PrecisionLender Support.
Posted Apr 07, 2020 - 09:50 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02, PL-Application-AU-01, PL-Application-CAC-01).