PrecisionLender Login Errors
Incident Report for PrecisionLender.com
Resolved
After additional monitoring, services have been fully restored and everything looks good so far. Users should be able to access PrecisionLender and price Opportunities as normal. Thank you for your patience throughout all of this.

For further information, see Ping Identity's status updates for this incident on their status page.
If you have any questions, please contact PrecisionLender Support.
Posted Dec 05, 2022 - 17:10 EST
Monitoring
PingOne has notified us that the underlying issues appear to have been resolved. We are monitoring the situation, and all users should be able to log in successfully at this time.
Posted Dec 05, 2022 - 16:22 EST
Update
We have identified that this issue is being caused by a global outage from our identity provider, PingOne. They are currently addressing the root cause and we will have more information shortly.
Posted Dec 05, 2022 - 16:12 EST
Investigating
We have identified an issue causing errors when attempting to access the PrecisionLender application. Users may be unable to login or price Opportunities in PrecisionLender during this time. We are very sorry for the inconvenience this has caused. Our team is closely investigating the root cause, and we will provide another update as soon as more information is available.
Posted Dec 05, 2022 - 15:40 EST
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02, PL-Application-NA-01, PL-Application-AU-01, PL-Application-CAC-01).