Inaccurate US Treasury Rates
Incident Report for PrecisionLender.com
Resolved
Opportunities affected have been fixed, and our Treasury rates going forward are correct. We will also continue to work on a fix for our Treasury Trailing Averages, which currently have no client impact. We are marking this issue as resolved, but we'll continue to monitor for any issues.
Posted 12 months ago. Oct 30, 2018 - 17:15 EDT
Update
We have implemented a fix for opportunities affected by incorrect Treasury rates between 10/17 and 10/23 and are in the process of reaching out to notify affected users. We are continuing to ensure that our Treasury rates are correct going forward. If you have any questions, please reach out to us.
Posted 12 months ago. Oct 26, 2018 - 17:37 EDT
Update
We are still working on a fix for opportunities and rate sheets affected by incorrect Treasury rates between 10/17 and 10/23, and we will reach out to affected users as soon as the fix is ready. Our Treasury rates for today are correct, and we will manually check rates to ensure tomorrow's Treasury rates are correct as well. If you have any questions, please reach out to us.
Posted 12 months ago. Oct 24, 2018 - 17:43 EDT
Monitoring
We are have identified an issue causing our US Treasury rates to be inaccurate. Opportunities saved with Treasury as an index or a funding curve with a pricing date between 10/17 and 10/23 may be affected. We are working with our provider to get a long-term fix for correct rates as quickly as we can. We are putting a temporary fix in place for tomorrow's rates, so tomorrow morning's Treasury rates will be correct as of EOD 10/23.
Posted 12 months ago. Oct 23, 2018 - 18:38 EDT
This incident affected: PrecisionLender Application (PL-Application-US-01, PL-Application-US-02).