PrecisonLender US01 Slowness
Incident Report for PrecisionLender.com
Resolved
#maintenance PrecisionLender is fully operational.
Posted Mar 15, 2017 - 18:11 EDT
Monitoring
#maintenance Our team is closely monitoring PrecisionLender as performance improves.
Posted Mar 15, 2017 - 14:01 EDT
Investigating
We have identified a problem causing slowness for some clients and our Development Team is working to correct it. We will update this page with more information soon.
Posted Mar 15, 2017 - 12:53 EDT