PrecisionLender Performance Degradation
Incident Report for PrecisionLender.com
Resolved
#maintenance PrecisionLender is fully operational.
Posted Feb 10, 2017 - 17:28 EST
Investigating
#maintenance
Posted Feb 10, 2017 - 17:09 EST
Monitoring
#maintenance Our team is closely monitoring PrecisionLender as performance improves.
Posted Feb 10, 2017 - 16:34 EST
Investigating
#maintenance Our Development team is reporting performance issues with the application. We are currently investigating and will update our support center with more information soon.
Posted Feb 10, 2017 - 15:11 EST