Outbound Emails Are Delayed
Incident Report for PrecisionLender.com
Postmortem

During this incident, we sent a high volume of emails intended for our developers to our email delivery provider. As part of their response plan, they prevented all emails from being delivered. We are working to refine our email delivery strategy to avoid this in the future.

Posted Feb 24, 2017 - 13:49 EST

Resolved
This incident has been resolved and emails are sending again in real time.
Posted Feb 18, 2017 - 02:59 EST
Investigating
#maintenance We are seeing a delay in outbound emails. We are currently investigating and will update this page with more information.
Posted Feb 17, 2017 - 19:12 EST